Forums  

Go Back   Forums > The Daihatsu Four Track Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 14-05-2017, 06:47 PM
Grease Monkey's Avatar
Grease Monkey Grease Monkey is offline
Member
 
Join Date: Dec 2009
Location: UK
Posts: 34
Unhappy My Fourtrack in trouble, help

Hi All me again, a little help if you can, having a little trouble, first noted it was giving poor power up a hill, and had to stop, could keep it going just, and after a time could drive away again.

I changed the fuel filter and it's been ok for a week or so, but it's now hard to get going, even hot, not like a 2.8 Daihatsu Fourtrak is it.

Fitted new set if heater plugs, but it's not really fixed anything

When I do get it going, it wont rev, may stop (cut out) and wont restart, kind of misfire as well.

Anyone any ideas, could it be the injection pump?.

Thanks Grease Monkey.
Reply With Quote
  #2  
Old 16-05-2017, 05:04 PM
Timbo's Avatar
Timbo Timbo is offline
Administrator
 
Join Date: Aug 2012
Posts: 88
Default

The pumps are full prof, they don't fail and not in that way, check the tank and line, the line rusts really bad.

But I would say the filter primer is letting air in, seen that a number of times, run the motor the primer should be rock hard after running, seen them not pump from the bleeder, the pump should send fuel from the pipe union and bleeder when pumping the primer.

Also check fuel pulls from the tank and line that goes to the filter using a bulb pump, there should be no air.

Hope this helps, Timbo.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 08:55 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.